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3D Scan Processing Procedures for Surfer 
 

Instructions Version 1.0 

Alistair Evans, 30 September 2008 

 

Pre-processing of Point Cloud 

Remove Extraneous Points 

The output from most scanners will include parts of the surface that are not of interest, and so it is 

usually easiest to delete these at the beginning. 

 

Rhino: 

• Import point cloud text file into Rhino 

o ‘File > Import’, select ‘Points File’ in ‘Files of type’, and choose file 

o In the Options window, the default Delimiter will usually be correct; if it does not work, 

open the file in a text editor to work out what type of delimiter the file uses. Check 

the ‘Create point cloud’ option. 

• It will often be useful to have a polygon surface of the file as well, as this is easier to 

visualise for alignment and choosing which points to remove. Some scanners/software will 

produce surface files as well (e.g. stl, dxf), so import these as well. If you only have the 

point cloud, you can use the boxed procedure below to create a dxf that you can then import 

into Rhino along with the point cloud. 

 

SurferManipulator: 

• Make a grid of the unrotated txt file 

o In ‘Utilities > File Format Conversion’ 

o Select ‘From file type:’ ‘Text file (irregular, e.g. Hawk)’ 

o Select ‘To file type:’ ‘Surfer Grid’ 

o In ‘Grid’ tab, select ‘Max. no. rows/cols’ and enter ‘200’ 

• Convert *200.grd to dxf to get *200.dxf 

o In ‘Utilities > File Format Conversion’ 

o From ‘Surfer grid file (*.grd)’ to ‘AutoCAD DXF file (*.dxf)’ 

 

• Import surface polygon file into Rhino into a different layer 

o If the ‘Layers’ window is not visible: ‘Edit > Layers > Edit Layers…’ 

o Select a different layer (e.g. Layer 01) by clicking to the left of the layer name so a tick 

appears in the left hand column. 

o ‘File > Import’, select relevant surface file type (e.g. stl, dxf) in ‘Files of type’, and 

select file (e.g. *200.dxf) 

 

• Align tooth/tooth row, e.g. anterior/posterior, horizontal occlusal surface 

o Select all objects (Ctrl+A) 

o ‘Transform > Rotate’ and follow instructions 

• Once alignment is complete, the point cloud must be separated into individual points 

(‘exploded’) 

o Select point cloud(s) 

o ‘Edit > Explode’ 

• Delete all points from exploded cloud from around the tooth 
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o This can be done by left-clicking and dragging a rectangle around points to select them, 

or type ‘Lasso’ in Command line and click and drag an irregular shape around 

points; then press ‘Delete’ key  

• Export the points to a text file 

o Select all points – either by hiding all other layers (press the light bulb symbol to toggle 

visible/invisible) and select all (Ctrl+A) or ‘Edit > Select Objects > Points’ 

o ‘File > Export Selected’ 

o ‘Save as type’ ‘Points File (*.txt)’ and save as ‘*-a.txt’ 

o Choose ‘Comma’ delimiter, 9 significant digits and uncheck ‘Surround values with 

double-quotes’ 

Creating, Processing and Manipulating Surfer Grids 

Once a 3D point cloud file has been converted to a Surfer grid, many manipulations (blanking, 

downsampling) can be carried out on the grd file. 

General SurferManipulator Settings 

SurferManipulator: 

• ‘Dir’ button: Press this to use the default directory. Set the default directory using ‘File > Set 

default directory’, navigate to a new directory and click ‘Update dir and exit’ 

• ‘Ref’ button: Press to refresh the file and directory list on the form 

Processing Single or Multiple Files 

Most functions in SurferManipulator can be carried out on many files at once. If you choose a file 

from the file list and select a function (e.g. Blank) then just that file will be processed. However, 

you can choose multiple files to be processed in the same manner with the same settings. The files 

to be processed are added to a filename list either individually or for all files in the directory. 

SurferManipulator: 

• To process multiple files 

o Either 1) Select the first file, click ‘Add filename’ (or double-click), select second file, 

click ‘Add filename’ (or double-click), etc. 

o Or 2) Click ‘Add all filenames’, which adds all files listed in the file box 

o The number of files added to the filename list is shown next to the ‘No. files’ label.\ 

• To clear the filename list, click ‘Clear filenames’ 

• If you would like to run the same procedure on the same filename list several times, uncheck 

the ‘Clear filenames after fn’ button. Once the function is run, the filename list is 

maintained. 

Convert to Surfer Grid 

SurferManipulator: 

• Create Surfer grid file (*.grd) from the txt file using ‘Utilities > File Format Conversion’ 

function 

o For ‘From file type:’ select ‘Text file (irregular, e.g. Hawk) (*.txt)’ 

o For ‘To file type:’ select ‘Surfer grid file (*.grd)’ 

o All main options are given in the ‘TXT to GRD’ tab 

o Select ‘Grid intervals’ and enter output grid resolution (distance between grid points) in 

same units as the text file (e.g. if text file is in mm, enter ‘0.02’ for 20 µm) 

o Use ‘Kriging’ as ‘Gridding method’ (default) 

o If the ‘Create blanking outline’ option is checked, the output will be a blanked Surfer 

grid file (‘*pb.grd’). If the ‘Remove undercuts’ option is also selected, the final file 
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will be named similar to: ‘*-uct48_12pb.grd’ This final grid is blanked, so that only 

the tooth surface remains in the grid. 

o Remove Undercuts in Joined or Realigned Scans 
� For full 3D scans, the point cloud must be turned into a 2.5D scan, i.e. only the 

surface visible from above (along the z axis) is present in the file, and there are 

no undercuts 

� If undercuts need to be removed, check ‘Remove undercuts’ option 

� If the ‘Use default settings’ option is checked, then it will calculate the required 

statistics from the grid intervals value. However, the detailed options are 

available on the ‘UC and blank’ tab, and are explained below 

� Primary Search Radius should be slightly above half of the resolution at which the 

scan the scan was made and will be interpolated onto a regular grid, e.g. if 

make a grid of 20 × 20 µm resolution in Surfer, Primary Search Radius should 

be about 12 µm. If undercuts appear in the gridded file, then increase the search 

radius to, say, 15 µm. The default settings give a threshold of 4 times the 

search radius, so if search radius is 12 µm, then threshold is 48 µm. 

� Outputted file will have extension ‘-uct’ + threshold + ‘_’ + search radius; e.g. ‘-

uct048_012’; a file with the rejected points will also be created, ending in 

‘_rej’ 

[Note: old format for undercut file is: ‘_t’ + threshold + ‘,’ + search radius; e.g. 

‘_t0.04,0.010’] 

o Automatically Generate Blanking File 

� If the tooth was cut out at point cloud stage (file name ending ‘-a’), then this 

option can be used to automatically create a Surfer blanking file that will 

isolate the area of interest 

� To automatically generate a blanking file before creating Surfer grid, check 

‘Create blanking outline’ option 

� If the ‘Use default settings’ option is checked, then it will calculate the required 

statistics from the grid intervals value. However, the detailed options are 

available on the ‘UC and blank’ tab, and are explained below 

� The resolution (‘Bin size’) at which the program will draw a blanking line around 

the point cloud should be roughly 1.5-3 times the resolution that the point 

cloud will be gridded at and the original surface was scanned at (e.g. 0.05 if 

gridding at resolution 0.02). The result is a blanking file ‘*pblnpts.bln’ that can 

be used to blank a grid 

� Check ‘Create points file with points in blanked area’. This creates a new txt file 

with an extension ‘p’ that has points distributed in the area outside the tooth. 

This reduces the time that it takes for Surfer to create a grid from the txt file 

Plotting in Surfer 

Visualisation of the Surfer grid can be done in a Surfer Plot window 

SurferManipulator: 

• Plot Relief Map of grid using ‘Utilities > Surfer Functions > Plot grid’ function 

o Select the grid to plot 

o Select required plot type (default is Relief map) and options 

o Click ‘Plot grid’ 
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Blanking in Surfer 

If it is necessary to remove parts of a Surfer grid (for example, to remove non-tooth parts of the grid 

or to isolate a single tooth) then the file must be ‘blanked’ in Surfer. If the ‘Create blanking outline’ 

option was used when the txt file was converted to Surfer grid, then this step is not necessary. 

SurferManipulator: 

• Blank the area outside the tooth using ‘Utilities > Surfer Functions > Digitise and blank 

grid’ function 

o Either 1) If tooth has been cut out of point cloud (file name ending ‘-a…p’) then: 

   Make sure the ‘*pblnpts.bln’ file is in the same directory as the grd file 

   Check ‘Use existing bln file’ with ‘Del. no. char. from grd fname’ = 0 

   Click ‘Blank’ 

o Or 2) If tooth was not cut out of point cloud then: 

   Click ‘Blank’ and follow instructions on screen 

Mirror Left Side (for MorphoBrowser) 

Move all grd files from left side of jaw (*-ul* and *-ll*) into a directory called ‘left not mirrored’ 

SurferManipulator: 

• Mirror the grids in the x-plane using ‘Utilities > Surfer Functions > Process grid’ function 

o Select ‘Mirror’ and ‘X’ and click ‘Process’ 

o Move mirrored files (*mx) back into the same directory as the files from the right side 

of the jaw 

Standardising Resolution of Scans (Downsampling) 

In order to run OPC analyses, it is best to standardise the resolution of scans to make results more 

comparable. This procedure will re-grid the data to an exact number of data rows. 

SurferManipulator: 

• Either 1) If tooth has been cut out of point cloud (file name ending ‘-a…p’), then 

o Copy the *pblnpts.bln file into same directory as the *p.txt file 

o Use ‘Utilities > Surfer Functions > Regrid at exact resolution’ function, select ‘Use txt 

files’, and set the ‘Exact no. rows/cols’ to 150. (Must change file types shown to 

‘Hawk text file (*.txt)’ rather than ‘Surfer grid file (*.grd)’ in order to select txt files 

from file list box.) This will generate three directories: b150_grd, b150b_grd and 

b150b_dat 

o For this method, you will need to mirror the resulting ‘150’ files. 

• Or 2) If the tooth was manually blanked using Surfer, then 

o Copy the *blnpts.bln file into the same directory as the *b.grd file 

o Use ‘Utilities > Surfer Functions > Regrid at exact resolution’ function, select ‘Use grid 

files’, set ‘Del from grd filename’ = 1, and set the ‘Exact no. rows/cols’ to 150. This 

will generate three directories: b150_grd, b150b_grd and b150b_dat. 

Blanking Individual Teeth 

To carry out analyses of individual teeth, the teeth can be separated into different Surfer grids. 

SurferManipulator: 

• Blank the borders between individual teeth using ‘Utilities > Surfer Functions > Digitise and 

blank grid’ function 

o Select file to process 

o Check ‘Multiple teeth’ in the ‘Digitise and blank grid’ frame 
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↓

o Check the teeth to be blanked, e.g. for teeth P4, M1 and M2, check only the boxes ‘p4’, 

‘m1’ and ‘m2’ 

o Click ‘Blank’ 

o Digitise the required number of borders between teeth. Do the most anterior border first 

(greatest y value). Draw the border from left to right, starting outside the grid area. 

Between each border, type ‘-1’ into the ‘digit.bln’ window on a new separate line. 

Do not put a ‘-1’ at the end of the file 

o Save the file as ‘digit.dat’ 

o Click ‘OK’ 

Combination Downsampling and Individual Teeth Blanking 

To carry out OPC analyses on individual teeth, it is necessary to standardise the resolution of the 

separate teeth, either to be the same as the downsampled whole tooth row or the same number of 

rows for each tooth. The following table gives directions and settings to be used in the ‘Digitise and 

blank grid’ and ‘Regrid at exact resolution’ functions in SurferManipulator. Follow the arrows to 

convert from one type to another. 

 
Full resolution grid 

Not blanked 

1 1.5 2 2.5

172

173

174

175

176

177

 
TestGridp.grd 

  

Select *.grd 

 

Digitise and blank area 

• Outside 

 

grd file generated: 

*b.grd 

bln file generated:  

*pblnpts.bln 

  

Full resolution grid 

Blanked 

1 1.5 2 2.5

172

173

174

175

176

177

 
TestGridpb.grd 

→ 
Select *b.grd 

bln file required:  

*pblnpts.bln 

 

Regrid at exact resolution 

• Use grid files 

Exact no.: 150 

• rows 

 

grd file generated: 

*b150b.grd 

Downsampled grid 

Blanked 

1 1.5 2 2.5

172

173

174

175

176

177

 
TestGridpb150b.grd 
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↓ ↓

↓

Select *b.grd 

 

Digitise and blank area 

• Multiple teeth 

� m1 � m2 � m3 

 

grd files generated:  

*pb-sm1b.grd 

*pb-sm2b.grd 

*pb-sm3b.grd 

bln files generated:  

*pb-sm1blnpts.bln 

*pb-sm2blnpts.bln 

*pb-sm3blnpts.bln 

 Select *b150b.grd 

bln files required:  

*pblnpts.bln 

*pb-sm1blnpts.bln 

*pb-sm2blnpts.bln 

*pb-sm3blnpts.bln 

 

Digitise and blank area 

• Multiple teeth 

� m1 � m2 � m3 

� Use existing bln file 

Del. no. char. from grd fname: 5 

 

grd files generated:  

*pb150b-sm1b.grd 

*pb150b-sm2b.grd 

*pb150b-sm3b.grd 

Full resolution separated teeth grids 

Blanked 

1 1.5 2 2.5

172

173

174

175

176

177

1 1.5 2 2.5

172

173

174

175

176

177

1 1.5 2 2.5

172

173

174

175

176

177

 
TestGridpb-sm1b.grd 

 Downsampled separated teeth grids 

- teeth same resolution as in row (e.g. 

80,50,20) 

Blanked 

1 1.5 2 2.5

172

173

174

175

176

177

1 1.5 2 2.5

172

173

174

175

176

177

1 1.5 2 2.5

172

173

174

175

176

177

 
TestGridpb150b-sm1b.grd 

Select *b-sm1b.grd, *b-sm2b.grd, *b-

sm3b.grd 

bln files required:  

*pblnpts.bln 

*pb-sm1blnpts.bln 

*pb-sm2blnpts.bln 

*pb-sm3blnpts.bln 

 

Regrid at exact resolution 

• Use grid files 

� Indiv. teeth (multi teeth 

blanked) 

Exact no.: 50 

• rows (Y) 

 

grd files generated:  

*pb-sm1b50b.grd 

*pb-sm2b50b.grd 

*pb-sm3b50b.grd 

  

Downsampled separated teeth grids  

- all teeth same no. rows (e.g. 50,50,50)  

Blanked 

1 1.5 2 2.5

175

175.5

176

176.5

177

0.8 1 1.2 1.4 1.6 1.8 2 2.2 2.4

173

173.2

173.4

173.6

173.8

174

174.2

174.4

174.6

174.8

1 1.2 1.4 1.6 1.8 2 2.2 2.4

171.2

171.4

171.6

171.8

172

172.2

172.4

172.6

172.8

173

 
TestGridpb-sm1b50b.grd 

  

 


